aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorW. Trevor King <wking@drexel.edu>2010-10-22 10:06:03 -0400
committerW. Trevor King <wking@drexel.edu>2010-10-22 10:06:03 -0400
commit4ee83193a9fb8433ca4769b85b9244dc5cd9d4fa (patch)
treead395f290fb03f98077ae02d4e50062a5502d188 /setup.py
parentc3d3f531440102986c83bf6611f45e81c9e636b3 (diff)
downloadbugseverywhere-4ee83193a9fb8433ca4769b85b9244dc5cd9d4fa.tar.gz
Allow command line overrides for built documentation.
For example, to install without documentation, use: $ make DOC= install which overrides Makefile's default DOC definition, setting it to the empty string.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py12
1 files changed, 9 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index da1ebad..b7fb839 100755
--- a/setup.py
+++ b/setup.py
@@ -1,11 +1,19 @@
#!/usr/bin/env python
from distutils.core import setup
+import os.path
+
from libbe import _version
rev_id = _version.version_info["revision"]
rev_date = _version.version_info["date"]
+data_files = []
+
+man_path = os.path.join('doc', 'man', 'be.1')
+if os.path.exists(man_path):
+ data_files.append(('share/man/man1', [man_path]))
+
setup(
name='Bugs Everywhere',
version=rev_date,
@@ -20,7 +28,5 @@ setup(
'libbe.ui.util',
'libbe.util'],
scripts=['be'],
- data_files=[
- ('share/man/man1', ['doc/man/be.1']),
- ]
+ data_files=data_files,
)