aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2024-03-31 00:20:18 +0100
committerMatěj Cepl <mcepl@cepl.eu>2024-03-31 00:20:18 +0100
commit6b02ecd5147d53c9eb05dd3f7334fe8f78a04287 (patch)
tree184cf588dd6617d195f8454938deece02fd68de2 /pyproject.toml
parent0436f5cebd288b906288be603b309907ca74be83 (diff)
downloadbugseverywhere-6b02ecd5147d53c9eb05dd3f7334fe8f78a04287.tar.gz
Replace manually written be script with standard entry-point.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml21
1 files changed, 13 insertions, 8 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 6db2b6f..8dd1fe6 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -29,6 +29,19 @@ classifiers = ["Development Status :: 4 - Beta",
description = "Bugtracker supporting distributed revision control"
readme = "README"
+[project.scripts]
+be = "libbe.ui.command_line:main"
+
+[tool.setuptools]
+packages=['libbe',
+ 'libbe.command',
+ 'libbe.storage',
+ 'libbe.storage.util',
+ 'libbe.storage.vcs',
+ 'libbe.ui',
+ 'libbe.ui.util',
+ 'libbe.util']
+
[tool.setuptools_scm]
@@ -48,14 +61,6 @@ readme = "README"
# version.version())),
# platforms=['all'],
# long_description=open(os.path.join(_this_dir, 'README.rst'), 'r').read(),
-# packages=['libbe',
-# 'libbe.command',
-# 'libbe.storage',
-# 'libbe.storage.util',
-# 'libbe.storage.vcs',
-# 'libbe.ui',
-# 'libbe.ui.util',
-# 'libbe.util'],
# scripts=['be'],
# data_files=data_files,
# requires=[