aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml11
1 files changed, 6 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index c9571c5..fd14017 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,7 +1,3 @@
-[tool.ruff]
-extend-exclude = ['typings/weechat.pyi']
-extend-select = ["I"]
-
[tool.poetry]
name = "wee-slack"
version = "3.0.0"
@@ -22,7 +18,7 @@ pytest = "^7.1.3"
pytest-cov = "^4.0.0"
typing-extensions = "^4.4.0"
pyright = "^1.1.323"
-ruff = "^0.1.7"
+ruff = "^0.2.2"
[tool.pylint.main]
ignored-modules = ["weechat"]
@@ -46,6 +42,11 @@ disable = [
strict = ["**"]
reportMissingModuleSource = false
+[tool.ruff]
+extend-exclude = ["typings/weechat.pyi"]
+
+[tool.ruff.lint]
+extend-select = ["I"]
[build-system]
requires = ["poetry-core"]