aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorTrygve Aaberge <trygveaa@gmail.com>2022-11-19 21:48:27 +0100
committerTrygve Aaberge <trygveaa@gmail.com>2024-02-18 11:32:53 +0100
commit1358241a612980781bc7f80dec67bc8de74a3903 (patch)
tree3aa8b4be8cb7428d997881b54c3f630aa9445b8d /pyproject.toml
parent0c599d0cd601bd491f4270a8ababab0ffe70b327 (diff)
downloadwee-slack-1358241a612980781bc7f80dec67bc8de74a3903.tar.gz
Add command to add workspace
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 145896e..ce9df58 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -30,14 +30,15 @@ ignored-modules = ["weechat"]
[tool.pylint."messages control"]
disable = [
- "dangerous-default-value", # inconvenient with types
+ "dangerous-default-value", # inconvenient with types
+ "inconsistent-return-statements", # no need when using typing
"invalid-name",
"missing-class-docstring",
"missing-function-docstring",
"missing-module-docstring",
- "no-member", # incorrect reports
- "protected-access", # covered by pyright
- "too-few-public-methods", # too often bad advice
+ "no-member", # incorrect reports
+ "protected-access", # covered by pyright
+ "too-few-public-methods", # too often bad advice
"too-many-arguments",
"too-many-instance-attributes",
]