aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorTrygve Aaberge <trygveaa@gmail.com>2024-02-21 18:51:35 +0100
committerTrygve Aaberge <trygveaa@gmail.com>2024-02-21 18:51:35 +0100
commit90125ea5ec54431bfafb504def8c4551e3d43fa4 (patch)
tree9dc911235b661e15e7ade665e96824404bd54cf4 /pyproject.toml
parent609e8c79786ae7510062cd40342bb5043065f98f (diff)
downloadwee-slack-90125ea5ec54431bfafb504def8c4551e3d43fa4.tar.gz
Specify minimum python version for tools in pyproject.toml
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index fd14017..3c32749 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,6 @@
+[project]
+requires-python = ">=3.7"
+
[tool.poetry]
name = "wee-slack"
version = "3.0.0"
@@ -39,6 +42,7 @@ disable = [
]
[tool.pyright]
+pythonVersion = "3.7"
strict = ["**"]
reportMissingModuleSource = false