aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2023-05-25 10:15:47 +0200
committerMatěj Cepl <mcepl@cepl.eu>2023-05-25 11:01:18 +0200
commitec4b49d843e67b31b33ac81bef55346353f1d04c (patch)
tree5f60ffae4d6ebe180c5ee4d51d468bf154535251 /setup.py
parent8006d981ce26fe8c1140e33b9476c08470d59f30 (diff)
downloadpygn-ec4b49d843e67b31b33ac81bef55346353f1d04c.tar.gz
refactor: rearrange the project to the src/ layout.0.10.3
Fix also pyproject.toml to generate what seems right. Add the explicit dependency on nntplib for Python >= 3.12 (gh#python/cpython!104894). Fixes: https://todo.sr.ht/~mcepl/pygn/7
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py43
1 files changed, 0 insertions, 43 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100644
index e763429..0000000
--- a/setup.py
+++ /dev/null
@@ -1,43 +0,0 @@
-#!/usr/bin/python
-# -*- coding: utf-8 -*-
-
-
-from __future__ import absolute_import
-from mail2news import VERSION, DESC
-import os.path
-from setuptools import setup
-
-
-def read(fname):
- return open(os.path.join(os.path.dirname(__file__), fname)).read()
-
-
-setup(name='pygn',
- version=VERSION, # the current Debian version is 0.9.8
- author="Cosimo Alfarano, Matej Cepl",
- author_email="kalfa@debian.org, mcepl@cepl.eu",
- description=DESC,
- long_description=read('README'),
- url='https://gitlab.com/mcepl/pyg',
- py_modules=['mail2news', 'news2mail', 'whitelist', 'wlp',
- 'wlp_parser'],
- test_suite="test",
- scripts=['pygm2n', 'pygn2m'],
- requires=['rply'],
- license="GPLv3",
- keywords=["nntp", "email", "gateway"],
- classifiers=[
- 'Development Status :: 3 - Alpha',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
- 'Intended Audience :: System Administrators',
- 'Topic :: Utilities',
- 'Topic :: Communications :: Usenet News',
- 'Environment :: Console',
- 'Operating System :: OS Independent',
- 'License :: OSI Approved :: GNU General Public License v3 (GPLv3)'
- ]
- )