diff options
author | Matěj Cepl <mcepl@cepl.eu> | 2020-07-01 16:16:44 +0200 |
---|---|---|
committer | Matěj Cepl <mcepl@cepl.eu> | 2020-07-01 16:19:16 +0200 |
commit | d5fc1faf927a5ff91f3416eb97014c0eadb14742 (patch) | |
tree | 2cb34082a4df13685c2ee0f46e1360cfdf4a8e88 /setup.py | |
parent | 19388fa2e3e6b02e7d7fd5c0b5dc9ee0cd9ef100 (diff) | |
download | pygn-d5fc1faf927a5ff91f3416eb97014c0eadb14742.tar.gz |
Sync with 0.10.1 release on PyPI0.10.1
Port to Python 3.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 15 |
1 files changed, 8 insertions, 7 deletions
@@ -1,6 +1,8 @@ -#!/usr/bin/python3 +#!/usr/bin/python # -*- coding: utf-8 -*- +from __future__ import print_function +from __future__ import absolute_import from mail2news import VERSION, DESC import os.path from setuptools import setup @@ -20,18 +22,17 @@ setup(name='pygn', py_modules=['mail2news', 'news2mail', 'setup', 'whitelist', 'wlp', 'wlp_parser'], test_suite="test", - entry_points={ - "console_scripts": [ - "pygm2n = mail2news:main", - "pygn2m = news2mail:main" - ] - }, + scripts=['pygm2n', 'pygn2m'], requires=['rply'], license="GPLv3", keywords=["nntp", "email", "gateway"], classifiers=[ 'Development Status :: 3 - Alpha', 'Programming Language :: Python :: 2.7', + 'Programming Language :: Python :: 3', + 'Programming Language :: Python :: 3.4', + 'Programming Language :: Python :: 3.5', + 'Programming Language :: Python :: 3.6', 'Intended Audience :: System Administrators', 'Topic :: Utilities', 'Topic :: Communications :: Usenet News', |