diff options
author | Matěj Cepl <mcepl@cepl.eu> | 2014-12-24 14:24:24 +0100 |
---|---|---|
committer | Matěj Cepl <mcepl@cepl.eu> | 2014-12-24 14:32:23 +0100 |
commit | 8af6ecfe31a7767f1d76f36581b01ddd26fb3220 (patch) | |
tree | a5cf60c5de6a34843fceb23895473cbb25c80fa2 /setup.py | |
parent | 45552a9cb1ac5433fd2010d1736b41a3393b9b6b (diff) | |
download | pygn-8af6ecfe31a7767f1d76f36581b01ddd26fb3220.tar.gz |
Mighty cleanup
* Use more of the standard methods for OrderedDicts
* remove pyginfo module (with SSOT being mail2news module)
* remove TODO, INSTALL, and changelog.Debian
* all FIXMEs and TODOs are filed as bugs in the issue tracker
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 14 |
1 files changed, 9 insertions, 5 deletions
@@ -1,9 +1,12 @@ #!/usr/bin/python +# -*- coding: utf-8 -*- +from __future__ import print_function import unittest import sys from distutils.core import setup, Extension, Command from distutils.command.build_ext import build_ext from subprocess import check_call +from mail2news import VERSION, DESC class RunTests(Command): @@ -49,11 +52,12 @@ wlp_module = Extension('wlp', 'wlp/commands.tab.c', 'wlp/lex.yy.c']) + setup(name='pyg', - version='0.9.9', # the current Debian version is 0.9.8 - author="Cosimo Alfarano", - author_email="kalfa@debian.org", # FIXME I am an contributor? - description='Python Mail <-> News Gateway', + version=VERSION, # the current Debian version is 0.9.8 + author="Cosimo Alfarano, Matej Cepl", + author_email="kalfa@debian.org, mcepl@cepl.eu", + description=DESC, long_description=''' Python Gateway Script from news to mail and vice versa. @@ -73,7 +77,7 @@ setup(name='pyg', It refers to rfc 822 (mail) and 850 (news). ''', - py_modules=['mail2news', 'news2mail', 'pyginfo', 'setup', 'whitelist'], + py_modules=['mail2news', 'news2mail', 'setup', 'whitelist'], ext_modules=[wlp_module], scripts=['pygm2n', 'pygn2m'], cmdclass={'build_ext': Build_WLP_ext, |