aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py35
1 files changed, 23 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index cb53d52..4fc30ca 100644
--- a/setup.py
+++ b/setup.py
@@ -1,17 +1,28 @@
import sys
from setuptools import setup
-from epy import __version__, __author__, __url__, __license__
+from epy import __version__, __author__, __email__, __url__, __license__
+
+with open("README.md", "r") as fh:
+ long_description = fh.read()
setup(
- name = "epy",
- version = __version__,
- description = "Terminal/CLI Epub Reader (Fork of https://github.com/wustho/epr with Reading Pctg)",
- url = __url__,
- author = __author__,
- license = __license__,
- keywords = ["EPUB", "EPUB3", "CLI", "Terminal", "Reader"],
- install_requires = ["mobi"] + (["windows-curses"] if sys.platform == "win32" else []),
- python_requires = "~=3.0",
- py_modules = ["epy"],
- entry_points = { "console_scripts": ["epy = epy:main"] }
+ name="epy-reader",
+ version=__version__,
+ description="Terminal/CLI Ebook (epub, fb2, mobi, azw3) Reader",
+ long_description=long_description,
+ long_description_content_type="text/markdown",
+ url=__url__,
+ author=__author__,
+ author_email=__email__,
+ license=__license__,
+ keywords=["epub", "epub3", "fb2", "mobi", "azw3", "CLI", "Terminal", "Reader"],
+ install_requires=["mobi"] + (["windows-curses"] if sys.platform == "win32" else []),
+ python_requires="~=3.0",
+ py_modules=["epy"],
+ entry_points={ "console_scripts": ["epy = epy:main"] },
+ classifiers=[
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: GNU General Public License v3 (GPLv3)",
+ "Operating System :: OS Independent",
+ ]
)