aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBenawi Adha <43810055+wustho@users.noreply.github.com>2019-10-23 22:54:29 +0700
committerGitHub <noreply@github.com>2019-10-23 22:54:29 +0700
commit00cbd0d665444da636ca11df0b77c50e51e98f27 (patch)
tree9b9f45ec9c1f0c40192f98aa47964739547f1fca /setup.py
parent8f8fae0bfd17bfae98c16f849dbfc48234ac2369 (diff)
downloadepy-00cbd0d665444da636ca11df0b77c50e51e98f27.tar.gz
Added setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 17 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..48bf88a
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,17 @@
+import sys
+from setuptools import setup
+from epr import __version__, __author__, __url__, __license__
+
+setup(
+ name = "epy",
+ version = __version__,
+ description = "Terminal/CLI Epub Reader (Fork of https://github.com/wustho/epr)",
+ url = __url__,
+ author = __author__,
+ license = __license__,
+ keywords = ["EPUB", "EPUB3", "CLI", "Terminal", "Reader"],
+ install_requires = ["windows-curses"] if sys.platform == "win32" else [],
+ python_requires = "~=3.0",
+ py_modules = ["epy"],
+ entry_points = { "console_scripts": ["epy = epy:main"] }
+)