diff options
author | benadha <benawiadha@gmail.com> | 2021-04-01 08:44:14 +0700 |
---|---|---|
committer | benadha <benawiadha@gmail.com> | 2021-04-01 08:44:14 +0700 |
commit | 6d89f3b440e46fd016ffb1973ce702d9a006b632 (patch) | |
tree | 856e68ee45e6220afabe41bdd137276aa917cd5e /setup.py | |
parent | 2d87cda4b5cbcfe01dfa92addca68a96e1dd0720 (diff) | |
download | epy-6d89f3b440e46fd016ffb1973ce702d9a006b632.tar.gz |
- Restructured setup.py to not import epy script
- Disabled page scroll animation on win32
- Fix: epub object has no attribute toc
- Formatting: elif -> if
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 17 |
1 files changed, 10 insertions, 7 deletions
@@ -1,22 +1,25 @@ import sys from setuptools import setup -from epy import __version__, __author__, __email__, __url__, __license__ with open("README.md", "r") as fh: long_description = fh.read() +requirements = ["mobi"] +if sys.platform == "win32": + requirements.append("windows-curses") + setup( name="epy-reader", - version=__version__, + version="2021.4.1", description="Terminal/CLI Ebook (epub, fb2, mobi, azw3) Reader", long_description=long_description, long_description_content_type="text/markdown", - url=__url__, - author=__author__, - author_email=__email__, - license=__license__, + url="https://github.com/wustho/epy", + author="Benawi Adha", + author_email="benawiadha@gmail.com", + license="GPL-3.0", keywords=["epub", "epub3", "fb2", "mobi", "azw3", "CLI", "Terminal", "Reader"], - install_requires=["mobi"] + (["windows-curses"] if sys.platform == "win32" else []), + install_requires=requirements, python_requires="~=3.0", py_modules=["epy"], entry_points={ "console_scripts": ["epy = epy:main"] }, |