aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2024-01-26 20:08:02 +0100
committerMatěj Cepl <mcepl@cepl.eu>2024-01-26 20:58:06 +0100
commitf03815055c4fae8acf8a00db0030223cbd375054 (patch)
treec2f0dfc99db640ab45e04fe10a78614fd9a7ec53 /pyproject.toml
parentae8b069807f62792b5aca2806ca17046475e9e30 (diff)
downloadepubgrep-f03815055c4fae8acf8a00db0030223cbd375054.tar.gz
build:convert from setup.py to pyproject.toml0.9.0
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..547984d
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,28 @@
+[build-system]
+requires = ["setuptools>=61.2"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "epubgrep"
+version = "0.9.0"
+authors = [{name = "Matěj Cepl", email = "mcepl@cepl.eu"}]
+description = "Grep through EPub files"
+classifiers = [
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.7",
+ "Environment :: Console",
+ "Intended Audience :: Information Technology",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+]
+urls = {Homepage = "https://git.cepl.eu/cgit/epubgrep"}
+dependencies = ["epub_meta"]
+
+[project.scripts]
+epubgrep = "epubgrep:main"