aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am57
1 files changed, 57 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..bcbc03c
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,57 @@
+AUTOMAKE_OPTIONS = 1.6
+INCLUDES = -I $(top_srcdir)/include
+LDADD = -L$(top_builddir)/lib -lsword
+
+
+noinst_PROGRAMS = keytest mgrtest parsekey listtest casttest modtest \
+compnone complzss localetest keycast introtest indextest configtest \
+romantest testblocks filtertest lextest swaptest genbooktest treeidxtest
+
+if ICU
+ICUPROG = icutest translittest tlitmgrtest
+else
+ICUPROG =
+endif
+
+noinst_PROGRAMS += $(ICUPROG)
+
+if ICU
+icutest_SOURCES = icutest.cpp
+translittest_SOURCES = translittest.cpp
+tlitmgrtest_SOURCES = tlitmgrtest.cpp
+tlitmgrtest_LDADD = -lustdio
+endif
+
+if ZLIB
+ZLIBPROG = compzip
+else
+ZLIBPROG =
+endif
+
+noinst_PROGRAMS += $(ZLIBPROG)
+
+if ZLIB
+compzip_SOURCES = compzip.cpp
+endif
+
+
+keytest_SOURCES = keytest.cpp
+mgrtest_SOURCES = mgrtest.cpp
+parsekey_SOURCES = parsekey.cpp
+listtest_SOURCES = listtest.cpp
+casttest_SOURCES = casttest.cpp
+modtest_SOURCES = modtest.cpp
+compnone_SOURCES = compnone.cpp
+complzss_SOURCES = complzss.cpp
+localetest_SOURCES = localetest.cpp
+keycast_SOURCES = keycast.cpp
+introtest_SOURCES = introtest.cpp
+indextest_SOURCES = indextest.cpp
+configtest_SOURCES = configtest.cpp
+romantest_SOURCES = romantest.cpp
+testblocks_SOURCES = testblocks.cpp
+filtertest_SOURCES = filtertest.cpp
+lextest_SOURCES = lextest.cpp
+swaptest_SOURCES = swaptest.cpp
+treeidxtest_SOURCES = treeidxtest.cpp
+genbooktest_SOURCES = genbooktest.cpp