aboutsummaryrefslogtreecommitdiffstats
path: root/Data-YAML-0.0.6/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Data-YAML-0.0.6/Makefile.PL')
-rw-r--r--Data-YAML-0.0.6/Makefile.PL22
1 files changed, 22 insertions, 0 deletions
diff --git a/Data-YAML-0.0.6/Makefile.PL b/Data-YAML-0.0.6/Makefile.PL
new file mode 100644
index 0000000..d04335d
--- /dev/null
+++ b/Data-YAML-0.0.6/Makefile.PL
@@ -0,0 +1,22 @@
+use strict;
+use warnings;
+use ExtUtils::MakeMaker;
+
+eval 'use ExtUtils::MakeMaker::Coverage';
+warn "Optional ExtUtils::MakeMaker::Coverage not available\n" if $@;
+
+WriteMakefile(
+ ( MM->can( 'signature_target' ) ? ( SIGN => 1 ) : () ),
+ NAME => 'Data::YAML',
+ AUTHOR => 'Andy Armstrong <andy@hexten.net>',
+ LICENSE => 'perl',
+ VERSION_FROM => 'lib/Data/YAML.pm',
+ ABSTRACT_FROM => 'lib/Data/YAML.pm',
+ PL_FILES => {},
+ PREREQ_PM => {
+ 'Test::More' => 0,
+ 'version' => 0,
+ },
+ dist => { COMPRESS => 'gzip -9f', SUFFIX => 'gz', },
+ clean => { FILES => 'Data-YAML-*' },
+);