aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorUnknown <tolsen@limebits.com>2008-06-26 15:16:08 -0400
committerMatěj Cepl <mcepl@cepl.eu>2023-04-29 18:18:22 +0200
commit6f76b677f683ab32ecf1083388d37379c8790c9a (patch)
tree7d50f9171276984b9dc2a14ab88041af3a55a719 /setup.py
parenta58af31d7e91494afe7951c1b345de3944054572 (diff)
downloadurllib2_kerberos-6f76b677f683ab32ecf1083388d37379c8790c9a.tar.gz
initial incomplete setup.py. committing in order to test keyword expansion
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py48
1 files changed, 5 insertions, 43 deletions
diff --git a/setup.py b/setup.py
index 54bd76e..f67454c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,47 +1,9 @@
-# Copyright 2008 Lime Nest LLC
-# Copyright 2008 Lime Spot LLC
-
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-
-# http://www.apache.org/licenses/LICENSE-2.0
-
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
from setuptools import setup
-import hgvers
-setup(
- name = "urllib2_kerberos",
- version = hgvers.version,
- py_modules = [ 'urllib2_kerberos' ],
-
-# install_requires = ['kerberos'],
+branches = "$branches$"
+node = "$node$"
+tags = "$tags$"
- author = "Tim Olsen",
- author_email = "tolsen@limespot.com",
- description = "Kerberos over HTTP Negotiate/SPNEGO support for urllib2",
- license = "Apache 2.0",
- url = "http://limedav.com/hg/urllib2_kerberos/",
- keywords = "urllib2 kerberos http negotiate spnego",
-
- classifiers = [
- 'Development Status :: 3 - Alpha',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: Apache Software License',
- 'Natural Language :: English',
- 'Operating System :: POSIX :: Linux',
- 'Programming Language :: Python',
- 'Topic :: Internet :: WWW/HTTP',
- 'Topic :: Software Development :: Libraries',
- 'Topic :: Software Development :: Libraries :: Python Modules',
- 'Topic :: System :: Systems Administration :: Authentication/Directory'
- ]
-
+setup(
+ name = "urllib2_kerberos"
)
-