aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@redhat.com>2011-11-21 15:54:09 +0100
committerMatěj Cepl <mcepl@redhat.com>2011-11-21 17:16:22 +0100
commit197ea8be5a2fb5e55083113a3225d6fa12371e24 (patch)
tree91fefdc545018790834c616333f2c82fa1ec573a /setup.py
parent793f46ddd47b8b78123fcfa68b62d377380bd366 (diff)
downloadjson_diff-197ea8be5a2fb5e55083113a3225d6fa12371e24.tar.gz
Two small nits in __main__ part.0.9.1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..7f3e86c
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,29 @@
+# -*- coding: utf-8 -*-
+from distutils.core import setup
+
+setup(
+ name = 'json_diff',
+ version = '0.9.1',
+ description = 'Generates diff between two JSON files',
+ author = 'Matěj Cepl',
+ author_email = 'mcepl@redhat.com',
+ url = 'https://gitorious.org/json_diff/mainline',
+ download_url = "http://mcepl.fedorapeople.org/scripts/json_diff-0.9.1.tar.gz",
+ py_modules = ['json_diff', 'test_json_diff', 'test_strings'],
+ package_data = ['test/*'],
+ long_description = """Compares two JSON files (http://json.org) and
+generates a new JSON file with the result. Allows exclusion of some
+keys from the comparison, or in other way to include only some keys.""",
+ keywords = ['json', 'diff'],
+ classifiers = [
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "Development Status :: 4 - Beta",
+ "Environment :: Console",
+ "Intended Audience :: Information Technology",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ "Topic :: Text Processing :: General",
+ ]
+)