aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/docs1
-rw-r--r--debian/install1
-rw-r--r--debian/pkg.pyinstall1
-rwxr-xr-xdebian/rules15
-rw-r--r--debian/sosreport.links1
5 files changed, 17 insertions, 2 deletions
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 00000000..475d728a
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+README.md AUTHORS
diff --git a/debian/install b/debian/install
new file mode 100644
index 00000000..6c41a24d
--- /dev/null
+++ b/debian/install
@@ -0,0 +1 @@
+sos.conf etc/
diff --git a/debian/pkg.pyinstall b/debian/pkg.pyinstall
deleted file mode 100644
index 8b68fc88..00000000
--- a/debian/pkg.pyinstall
+++ /dev/null
@@ -1 +0,0 @@
-sos/* /usr/share/sosreport/
diff --git a/debian/rules b/debian/rules
index 15b7f5ec..90637142 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,4 +5,17 @@ DH_ALWAYS_EXCLUDE=.git
%:
dh $@ --with python2
-override_dh_auto_test:
+override_dh_auto_install:
+ python setup.py \
+ install \
+ --install-lib=usr/share/sosreport/ \
+ --install-data=usr/ \
+ --install-scripts=usr/share/sosreport/ \
+ --root=$(CURDIR)/debian/sosreport/ \
+ --no-compile -O0
+
+override_dh_clean:
+ rm -rf build/
+ rm -rf dist/
+ find . -name '*.pyc' -delete
+
diff --git a/debian/sosreport.links b/debian/sosreport.links
new file mode 100644
index 00000000..04d91625
--- /dev/null
+++ b/debian/sosreport.links
@@ -0,0 +1 @@
+/usr/share/sosreport/sosreport /usr/bin/sosreport