aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 14 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 15b7f5ec..90637142 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,4 +5,17 @@ DH_ALWAYS_EXCLUDE=.git
%:
dh $@ --with python2
-override_dh_auto_test:
+override_dh_auto_install:
+ python setup.py \
+ install \
+ --install-lib=usr/share/sosreport/ \
+ --install-data=usr/ \
+ --install-scripts=usr/share/sosreport/ \
+ --root=$(CURDIR)/debian/sosreport/ \
+ --no-compile -O0
+
+override_dh_clean:
+ rm -rf build/
+ rm -rf dist/
+ find . -name '*.pyc' -delete
+