aboutsummaryrefslogtreecommitdiffstats
path: root/src/sos-internal.spec
diff options
context:
space:
mode:
authornavid <navid@ef72aa8b-4018-0410-8976-d6e080ef94d8>2007-10-05 09:56:44 +0000
committernavid <navid@ef72aa8b-4018-0410-8976-d6e080ef94d8>2007-10-05 09:56:44 +0000
commit9b1907d400e4b0c00faed51ef6b404252c5a0b62 (patch)
tree3103146daea9940d58a1334edac1befac94bdf64 /src/sos-internal.spec
parentbb64815142fcf2af6c519dcb78a92f6725fb200d (diff)
downloadsos-9b1907d400e4b0c00faed51ef6b404252c5a0b62.tar.gz
added support for GPG encryption of reports
git-svn-id: svn+ssh://svn.fedorahosted.org/svn/sos/trunk@417 ef72aa8b-4018-0410-8976-d6e080ef94d8
Diffstat (limited to 'src/sos-internal.spec')
-rw-r--r--src/sos-internal.spec45
1 files changed, 45 insertions, 0 deletions
diff --git a/src/sos-internal.spec b/src/sos-internal.spec
new file mode 100644
index 00000000..86f0cc73
--- /dev/null
+++ b/src/sos-internal.spec
@@ -0,0 +1,45 @@
+%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
+
+%define name sos-internal
+%define version 1.0
+%define release 0
+
+Summary: Red Hat Support GPG private key
+Name: %{name}
+Version: %{version}
+Release: %{release}%{?dist}
+Group: Application/Tools
+
+Source0: rhsupport.pub
+Source1: rhsupport.key
+License: GPL
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
+BuildArch: noarch
+Url: http://sos.108.redhat.com/
+
+%description
+Sos is a set of tools that gathers information about system
+hardware and configuration. The information can then be used for
+diagnostic purposes and debugging. Sos is commonly used to help
+support technicians and developers.
+
+%install
+rm -rf ${RPM_BUILD_ROOT}
+install -D -m600 %{SOURCE0} ${RPM_BUILD_ROOT}/usr/share/sos/rhsupport.pub
+install -D -m644 %{SOURCE1} ${RPM_BUILD_ROOT}/usr/share/sos/rhsupport.key
+
+%clean
+rm -rf ${RPM_BUILD_ROOT}
+
+%post
+/usr/bin/gpg --import /usr/share/sos/rhsupport.pub
+/usr/bin/gpg --allow-secret-key-import --import /usr/share/sos/rhsupport.key
+
+%files
+%defattr(-,root,root,-)
+/usr/share/sos/rhsupport.pub
+/usr/share/sos/rhsupport.key
+
+%changelog
+* Wed Sep 4 2007 Navid Sheikhol-Eslami <navid at redhat dot com> - 1.0
+- the GPG key will be regenerated every time this package is built