aboutsummaryrefslogtreecommitdiffstats
path: root/src/setup.py
diff options
context:
space:
mode:
authorsconklin <sconklin@ef72aa8b-4018-0410-8976-d6e080ef94d8>2006-07-12 19:17:06 +0000
committersconklin <sconklin@ef72aa8b-4018-0410-8976-d6e080ef94d8>2006-07-12 19:17:06 +0000
commitb7e0351d69f561d2c25878dc5269bdeb290ed059 (patch)
tree35910635986055e7ca9cf7632158b9e205a7dc00 /src/setup.py
parent8521ca3b4db9775c09ae29af336abba99e939a2b (diff)
downloadsos-b7e0351d69f561d2c25878dc5269bdeb290ed059.tar.gz
Initial import, moved project from internal server to 108
git-svn-id: svn+ssh://svn.fedorahosted.org/svn/sos/trunk@5 ef72aa8b-4018-0410-8976-d6e080ef94d8
Diffstat (limited to 'src/setup.py')
-rw-r--r--src/setup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/setup.py b/src/setup.py
new file mode 100644
index 00000000..c51a57b1
--- /dev/null
+++ b/src/setup.py
@@ -0,0 +1,27 @@
+"""
+setup.py - Setup package with the help from Python's DistUtils
+"""
+
+from distutils.core import setup
+#from distutils.core import setup, Extension
+from ConfigParser import ConfigParser
+import sys,os,time
+
+# change release in spec file along with this version string
+setup(
+ name = 'sos',
+ version = '0.1.6',
+ description = 'System Support Tools',
+ long_description = """Sos is a set of tools that gathers information about system
+ hardware and configuration. The information can then be used for
+ diagnostic purposes and debugging. Sos is commonly used to help
+ support technicians and developers.""",
+ author = 'Steve Conklin, et al.',
+ author_email = 'sconklin@redhat.com',
+ url = 'http://support.redhat.com/',
+ packages = ['sos', 'sos.plugins'],
+ scripts = [],
+ package_dir = {'': 'lib',},
+ # data_files is broken for building dists, works for installs
+ data_files = [('/usr/sbin', ['sosreport'])]
+)