diff options
author | Bryn M. Reeves <bmr@redhat.com> | 2016-02-05 19:47:56 +0000 |
---|---|---|
committer | Bryn M. Reeves <bmr@redhat.com> | 2016-02-05 19:47:56 +0000 |
commit | 6ce445496b436ecb42c8cc44f471d2617ebd2830 (patch) | |
tree | 34c36648dbe06b80657fb9436a4f6f28f42da11a /setup.py | |
parent | 8498670f735fbc2db2ab7b7d51d23c9266e1b3ea (diff) | |
download | sos-6ce445496b436ecb42c8cc44f471d2617ebd2830.tar.gz |
[setup] fix RPM distutils builds
Fix the summary field to not contain embedded newlines and work
around a bug in distutil's handling of gzipped man pages in
setup.py.
Signed-off-by: Bryn M. Reeves <bmr@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 18 |
1 files changed, 12 insertions, 6 deletions
@@ -8,6 +8,7 @@ from distutils.log import warn, info, error import glob import os +import re import subprocess import sys @@ -49,13 +50,18 @@ class InstallData(install_data): data_files.append((dest, [mo])) return data_files -setup(name='sosreport', + # Workaround https://bugs.python.org/issue644744 + def copy_file (self, filename, dirname): + (out, _) = install_data.copy_file(self, filename, dirname) + # match for man pages + if re.search(r'/man/man\d/.+\.\d$', out): + return (out+".gz", _) + return (out, _) + +setup(name='sos', version=VERSION, - description="""Set of tools to gather troubleshooting data - from a system Sos is a set of tools that gathers information about system - hardware and configuration. The information can then be used for - diagnostic purposes and debugging. Sos is commonly used to help - support technicians and developers.""", + description=("""A set of tools to gather troubleshooting""" + """ information from a system."""), author='Bryn M. Reeves', author_email='bmr@redhat.com', url='https://github.com/sosreport/sos', |