diff options
author | Jake Hunsaker <jhunsake@redhat.com> | 2017-12-19 17:17:53 -0500 |
---|---|---|
committer | Bryn M. Reeves <bmr@redhat.com> | 2018-06-06 10:45:35 +0100 |
commit | 04df94418071b48a15aa80636dd34243ed374d2c (patch) | |
tree | 3893fcf2a4bd5c12c2d1ded974defcf40b017917 /setup.py | |
parent | 2fcf5f09e0e809124aeb5e262eeecbe446824efc (diff) | |
download | sos-04df94418071b48a15aa80636dd34243ed374d2c.tar.gz |
[sosreport] Concurrently run plugins
Changes sos to run plugins concurrently. By default sos will now use
four (4) threads to run plugins, allowing for faster overall execution
of sosreport. The number of threads can be changed using the --threads
commandline option.
Plugins now also have a timeout applied to them as a whole to avoid
situations where sosreport appears to be hung. If a plugin exceeds the
timeout threshold, the plugin will be terminated immediately. - this
allows sos to not only continue running normally, but should still allow
for collection of commands run by the plugin up until it was terminated.
The timeout is plugin controlled, and defaults to 300 seconds if not
set.
Note that for python2 environments, this adds a dependency on
python-futures. The futures module is present in the standard library
for python3 environments.
Signed-off-by: Jake Hunsaker <jhunsake@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -73,7 +73,7 @@ setup(name='sos', ], packages=['sos', 'sos.plugins', 'sos.policies'], cmdclass={'build': BuildData, 'install_data': InstallData}, - requires=['six'], + requires=['six', 'futures'], ) |