diff options
author | Bryn M. Reeves <bmr@redhat.com> | 2015-02-20 14:57:37 +0000 |
---|---|---|
committer | Bryn M. Reeves <bmr@redhat.com> | 2015-02-20 15:00:46 +0000 |
commit | 1b15a70ddda3c0f12124a1f53398cc09412981bf (patch) | |
tree | fe55e5dee9b1185d851c3b480dfe9613b1571067 /setup.py | |
parent | edd516836e1070df6c95bd2d71e6b82feaa10a11 (diff) | |
download | sos-1b15a70ddda3c0f12124a1f53398cc09412981bf.tar.gz |
Revert "[build] install sos.conf from setup.py"
This reverts commit edd516836e1070df6c95bd2d71e6b82feaa10a11.
It turns out installing things to /etc from setup.py is a terrible
idea; distutils deliberately makes this difficult (by design) and
expects you to either use data resources (installed under /usr on
*nix platforms) or provide a script or other means to set up the
configuration post-install[1][2].
Instead revert to simply installing the python code and docs via
setup.py and allow distribution packagers to handle the config
file installation as they choose.
[1] http://stackoverflow.com/questions/10456279/python-setuptools
[2] http://stackoverflow.com/questions/3325606/how-to-handle-conf
Signed-off-by: Bryn M. Reeves <bmr@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 1 insertions, 3 deletions
@@ -64,9 +64,7 @@ setup(name='sosreport', data_files=[ ('share/man/man1', ['man/en/sosreport.1']), ('share/man/man5', ['man/en/sos.conf.5']), - # FIXME - does not support --prefix - ('/etc', ['sos.conf']) - ], + ], packages=['sos', 'sos.plugins', 'sos.policies'], cmdclass={'build': BuildData, 'install_data': InstallData}, requires=['six'], |