summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/patchsys-quilt.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/patchsys-quilt.mk b/debian/patchsys-quilt.mk
index 5e6d15d..cae029e 100644
--- a/debian/patchsys-quilt.mk
+++ b/debian/patchsys-quilt.mk
@@ -74,12 +74,12 @@ debian/stamp-patched:
fi
# quilt exits with 2 as return when there was nothing to do.
# That's not an error here (but it's usefull to break loops in crude scripts)
- $(DEB_QUILT_CMD) push -a || test $$? == 2
+ $(DEB_QUILT_CMD) push -a || test $$? = 2
touch debian/stamp-patched
reverse-patches:
if [ -d "$(DEB_SRCDIR)" ] ; then \
- $(DEB_QUILT_CMD) pop -a -R || test $$? == 2 ; \
+ $(DEB_QUILT_CMD) pop -a -R || test $$? = 2 ; \
fi
if [ -n "$(DEB_QUILT_PATCHDIR_LINK)" ] ; then \
if [ -L $(DEB_SRCDIR)/$(DEB_QUILT_PATCHDIR_LINK) ] ; then \