summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 2 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 16f9b88..77e7ddd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,25 +50,13 @@ QUILT_COMPAT_PROG_PATH(BASH, bash)
# though the result /could/ be available to us directly as $BASH_VERSION we
# don't want to use, or trust it, incase the user is specifying a different
# bash executable.
-if `$BASH -c '[[ "$BASH_VERSION" \< "2.04" ]]'` ; then
+if `$BASH -c '[[ "$BASH_VERSION" \< "3.2" ]]'` ; then
AC_MSG_ERROR([
-$PACKAGE_NAME requires at least version 2.04 of bash, you can download a current
+$PACKAGE_NAME requires at least version 3.2 of bash, you can download a current
version of bash from ftp.gnu.org
])
fi
-AC_MSG_CHECKING(whether $BASH quoting works)
-if test `$BASH -c "echo \"\\\$(set -- \\\$'a b'; echo \\\$#)\"" 2>/dev/null` = "1"; then
- AC_MSG_RESULT(yes)
-else
- AC_MSG_RESULT(no)
- AC_MSG_ERROR([
-You have a version of `bash' which suffers from a quoting bug.
-This is a known bug of bash 3.1, which was fixed by patch bash31-011.
-You can get this patch at ftp://ftp.gnu.org/gnu/bash/
-])
-fi
-
QUILT_COMPAT_PROG_PATH(CP, cp, [gcp cp])
QUILT_COMPAT_PROG_PATH(DATE, date, [gdate date])