summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f23dbec..55dc93f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT([quilt],[0.24],[quilt-dev@nongnu.org])
AC_CONFIG_AUX_DIR(config)
AC_PREREQ(2.53)
-AC_REVISION ($Revision: 1.15 $)
+AC_REVISION ($Revision: 1.16 $)
PACKAGE_RELEASE=1
AC_SUBST(PACKAGE_RELEASE)
@@ -216,6 +216,14 @@ if test -z "$MSGFMT" ; then
AC_MSG_NOTICE([Building without natural language support])
fi
+dnl Determine where package documentation is supposed to go
+if test -n "$RPM_DOC_DIR" ; then
+ docdir="$RPM_DOC_DIR"
+else
+ docdir='$(datadir)/doc'
+fi
+AC_SUBST(docdir)
+
dnl Check for rpmbuild (v4) vs. rpm (v3)
AC_PATH_PROGS(RPMBUILD, [rpmbuild rpm])
AC_SUBST(RPMBUILD)