summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 708f59e..cffd83b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT([quilt],[0.22],[quilt-dev@nongnu.org])
AC_CONFIG_AUX_DIR(config)
AC_PREREQ(2.53)
-AC_REVISION ($Revision: 1.10 $)
+AC_REVISION ($Revision: 1.11 $)
PACKAGE_RELEASE=1
AC_SUBST(PACKAGE_RELEASE)
@@ -152,6 +152,24 @@ else
AC_MSG_RESULT(yes)
fi
+# Check for diffstat
+AC_ARG_WITH(diffstat, AC_HELP_STRING(
+ [--with-diffstat], [name of the diffstat executable to use]),
+ [
+ DIFFSTAT="$withval"
+ AC_SUBST(DIFFSTAT)
+ AC_MSG_NOTICE([Using diffstat executable $DIFFSTAT])
+ ],[
+ AC_PATH_PROG(DIFFSTAT, diffstat)
+ ])
+if test -z "$DIFFSTAT"; then
+ AC_MSG_WARN([
+diffstat does not appear to be in your path, this is not a fatal error however
+$PACKAGE_NAME has increased functionality if diffstat exists. If you have diffstat
+you can specify the location the option '--with-diffstat'.
+])
+fi
+
# Check for NLS
AC_ARG_ENABLE(nls, AC_HELP_STRING(
[--enable-nls], [include natural language support]))