summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3e146d0..3f2acd6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT([quilt],[0.42],[quilt-dev@nongnu.org])
AC_CONFIG_AUX_DIR(config)
AC_PREREQ(2.53)
-AC_REVISION ($Revision: 1.39 $)
+AC_REVISION ($Revision: 1.40 $)
PACKAGE_RELEASE=1
AC_SUBST(PACKAGE_RELEASE)
@@ -17,6 +17,12 @@ AC_CHECK_FUNCS([strrchr])
AC_C_CONST
AC_FUNC_STAT
+if test "$ac_compiler_gnu" = "yes"; then
+ CFLAGS="$CFLAGS -Wall"
+fi
+EXEEXT="$ac_cv_exeext"
+AC_SUBST(EXEEXT)
+
AC_PROG_INSTALL
AC_SYS_INTERPRETER