summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorMartin Quinson <mquinson@debian.org>2003-01-21 10:00:37 +0000
committerMartin Quinson <mquinson@debian.org>2003-01-21 10:00:37 +0000
commit48f8a12f64ae0a43196a8b6048495af8e3a6146f (patch)
treead01dc62cc0a76eb82604356656e0dadf24219e9 /debian/rules
parentfc6281de97e0b6f4b727936d2779695caee2d78f (diff)
downloadquilt-48f8a12f64ae0a43196a8b6048495af8e3a6146f.tar.gz
What to build a debian package
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules87
1 files changed, 87 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e20e399
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,87 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# This is the debhelper compatibility version to use.
+export DH_COMPAT=3
+
+
+
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -g
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ #/usr/bin/docbook-to-man debian/patchstack.sgml > patchstack.1
+ $(MAKE) prefix=/usr BUILD_ROOT=$(CURDIR)/debian/quilt
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ $(MAKE) prefix=/usr BUILD_ROOT=$(CURDIR)/debian/quilt clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/patchstack.
+ $(MAKE) prefix=/usr BUILD_ROOT=$(CURDIR)/debian/quilt install
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installdocs
+ dh_installexamples
+ dh_installmenu
+# dh_installemacsen
+ dh_installman
+ dh_installinfo
+# dh_undocumented
+ dh_installchangelogs
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_makeshlibs
+ dh_installdeb
+# dh_perl
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure