summaryrefslogtreecommitdiffstats
path: root/debian/patchsys-quilt.mk
diff options
context:
space:
mode:
authorMartin Quinson <mquinson@debian.org>2004-12-08 15:30:47 +0000
committerMartin Quinson <mquinson@debian.org>2004-12-08 15:30:47 +0000
commit51eaf66b2df8e63f276132dc0e2609356fe71bca (patch)
treec072c0625fa5404c39efd50ed00c14d03f9788d0 /debian/patchsys-quilt.mk
parent83a05afaca7f1ec7a8f5428030360742850ca4df (diff)
downloadquilt-51eaf66b2df8e63f276132dc0e2609356fe71bca.tar.gz
Fix a bashism
Diffstat (limited to 'debian/patchsys-quilt.mk')
-rw-r--r--debian/patchsys-quilt.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/patchsys-quilt.mk b/debian/patchsys-quilt.mk
index 5e6d15d..cae029e 100644
--- a/debian/patchsys-quilt.mk
+++ b/debian/patchsys-quilt.mk
@@ -74,12 +74,12 @@ debian/stamp-patched:
fi
# quilt exits with 2 as return when there was nothing to do.
# That's not an error here (but it's usefull to break loops in crude scripts)
- $(DEB_QUILT_CMD) push -a || test $$? == 2
+ $(DEB_QUILT_CMD) push -a || test $$? = 2
touch debian/stamp-patched
reverse-patches:
if [ -d "$(DEB_SRCDIR)" ] ; then \
- $(DEB_QUILT_CMD) pop -a -R || test $$? == 2 ; \
+ $(DEB_QUILT_CMD) pop -a -R || test $$? = 2 ; \
fi
if [ -n "$(DEB_QUILT_PATCHDIR_LINK)" ] ; then \
if [ -L $(DEB_SRCDIR)/$(DEB_QUILT_PATCHDIR_LINK) ] ; then \