summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJean Delvare <khali@linux-fr.org>2006-06-24 10:07:41 +0000
committerJean Delvare <khali@linux-fr.org>2006-06-24 10:07:41 +0000
commita4b2cb60c6351c7388aae47413fc711f8f9783b4 (patch)
tree557c35bae2668a81ad72f47729528b33ec833701 /configure.ac
parent35ded07912133bcce6226c73e474e96c4f89a8aa (diff)
downloadquilt-a4b2cb60c6351c7388aae47413fc711f8f9783b4.tar.gz
- configure.ac: Test for bash 3.1 quoting bug (#16763).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c993fff..e9d5eba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT([quilt],[0.45],[quilt-dev@nongnu.org])
AC_CONFIG_AUX_DIR(config)
AC_PREREQ(2.53)
-AC_REVISION ($Revision: 1.79 $)
+AC_REVISION ($Revision: 1.80 $)
PACKAGE_RELEASE=1
AC_SUBST(PACKAGE_RELEASE)
@@ -56,6 +56,18 @@ version of bash from ftp.gnu.org
])
fi
+AC_MSG_CHECKING(whether $BASH quoting works)
+if test `$BASH -c "echo \"\\\$(set -- \\\$'a b'; echo \\\$#)\"" 2>/dev/null` = "1"; then
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([
+You have a version of `bash' which suffers from a quoting bug.
+This is a known bug of bash 3.1, which was fixed by patch bash31-011.
+You can get this patch at ftp://ftp.gnu.org/gnu/bash/
+])
+fi
+
QUILT_COMPAT_PROG_PATH(CP, cp, [gcp cp])
AC_MSG_CHECKING(whether $CP -l works)
touch conftest.1