summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJean Delvare <jdelvare@suse.de>2010-06-23 13:41:20 +0200
committerJean Delvare <jdelvare@suse.de>2010-06-23 13:41:20 +0200
commit38df0b210c3df67f3e784af92232ae1946b98ecd (patch)
tree2f444cb9d7018afc18f8886b1dd0ca23fcebdb3c /configure.ac
parent7932d45a8f12441143bd495b83fb1e864d883f35 (diff)
downloadquilt-38df0b210c3df67f3e784af92232ae1946b98ecd.tar.gz
Properly detect newer versions of GNU patch
New versions of GNU patch present themselves as "GNU patch" instead of just "patch".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9d4a62e..cc850fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -262,7 +262,11 @@ fi
AC_MSG_CHECKING([the version of $PATCH])
if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
set -- `$PATCH --version 2> /dev/null`
- patch_version=$2
+ if test x$1 = xGNU ; then
+ patch_version=$3
+ else
+ patch_version=$2
+ fi
AC_MSG_RESULT($patch_version)
saved_IFS=$IFS; IFS='.'
set -- $patch_version