summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Gruenbacher <agruen@linbit.com>2012-02-11 19:11:17 +0100
committerAndreas Gruenbacher <agruen@linbit.com>2012-02-11 19:17:54 +0100
commitcc4ed02d16bfd3780adab593beb71407181df4ac (patch)
tree0a37ff148034f86dd31c61df8555cb9aeb27496d /configure.ac
parentc5b99140789c7624a9bb407efb55d5a9bc37a174 (diff)
downloadquilt-cc4ed02d16bfd3780adab593beb71407181df4ac.tar.gz
quilt mail: Improve error reporting (requires bash 3.2)
Improve error checking by using the "pipefail" option, available since bash 3. Since bash 3.1 is known to be broken already, require bash 3.2 directly. Report the patch name as well when "quilt mail" finds a problem with a patch.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 2 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 16f9b88..77e7ddd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,25 +50,13 @@ QUILT_COMPAT_PROG_PATH(BASH, bash)
# though the result /could/ be available to us directly as $BASH_VERSION we
# don't want to use, or trust it, incase the user is specifying a different
# bash executable.
-if `$BASH -c '[[ "$BASH_VERSION" \< "2.04" ]]'` ; then
+if `$BASH -c '[[ "$BASH_VERSION" \< "3.2" ]]'` ; then
AC_MSG_ERROR([
-$PACKAGE_NAME requires at least version 2.04 of bash, you can download a current
+$PACKAGE_NAME requires at least version 3.2 of bash, you can download a current
version of bash from ftp.gnu.org
])
fi
-AC_MSG_CHECKING(whether $BASH quoting works)
-if test `$BASH -c "echo \"\\\$(set -- \\\$'a b'; echo \\\$#)\"" 2>/dev/null` = "1"; then
- AC_MSG_RESULT(yes)
-else
- AC_MSG_RESULT(no)
- AC_MSG_ERROR([
-You have a version of `bash' which suffers from a quoting bug.
-This is a known bug of bash 3.1, which was fixed by patch bash31-011.
-You can get this patch at ftp://ftp.gnu.org/gnu/bash/
-])
-fi
-
QUILT_COMPAT_PROG_PATH(CP, cp, [gcp cp])
QUILT_COMPAT_PROG_PATH(DATE, date, [gdate date])