summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Gruenbacher <agruen@suse.de>2006-01-31 12:45:35 +0000
committerAndreas Gruenbacher <agruen@suse.de>2006-01-31 12:45:35 +0000
commitc5c34148fe671cceb3da919da6538858565c96a7 (patch)
tree2c9ed7f4e36ae7447602919e4de888fb323ecb68 /configure.ac
parentf889bf80603452be10399cca984fb853d87516c6 (diff)
downloadquilt-c5c34148fe671cceb3da919da6538858565c96a7.tar.gz
- Check for GNU uniq, and test if uniq -D is supported (from Gary
V. Vaughan).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 72324ec..8336028 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT([quilt],[0.42],[quilt-dev@nongnu.org])
AC_CONFIG_AUX_DIR(config)
AC_PREREQ(2.53)
-AC_REVISION ($Revision: 1.68 $)
+AC_REVISION ($Revision: 1.69 $)
PACKAGE_RELEASE=1
AC_SUBST(PACKAGE_RELEASE)
@@ -69,6 +69,18 @@ You can download GNU fileutils from ftp.gnu.org
])
fi
+QUILT_COMPAT_PROG_PATH(UNIQ, uniq, [guniq uniq])
+AC_MSG_CHECKING(whether $UNIQ -D works)
+if echo 'foo' | $UNIQ -D >/dev/null 2>/dev/null; then
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_ERROR([no
+
+You appear to have a `uniq' that does not support printing only
+duplicates. You can download GNU coreutils from ftp.gnu.org.
+])
+fi
+
QUILT_COMPAT_PROG_PATH(DATE, date, [gdate date])
QUILT_COMPAT_PROG_PATH(PERL, perl, [perl perl5])
QUILT_COMPAT_PROG_PATH(GREP, grep)