summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Gruenbacher <agruen@suse.de>2005-01-23 05:01:00 +0000
committerAndreas Gruenbacher <agruen@suse.de>2005-01-23 05:01:00 +0000
commit0ae231e732db3af8de72ec7c846ed72a7f9c9fd3 (patch)
tree4e677efe26a93898d32a0f1741163f2dd39d312d /configure.ac
parentcaf1482275106e47eefe58669156def40acadae3 (diff)
downloadquilt-0ae231e732db3af8de72ec7c846ed72a7f9c9fd3.tar.gz
- Add mail command, doc/README.MAIL and example ``mail'' command
filter in quilt.quiltrc. - Bump version to 0.38.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 22 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 91e1b8e..36862e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,8 +1,8 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([quilt],[0.37],[quilt-dev@nongnu.org])
+AC_INIT([quilt],[0.38],[quilt-dev@nongnu.org])
AC_CONFIG_AUX_DIR(config)
AC_PREREQ(2.53)
-AC_REVISION ($Revision: 1.32 $)
+AC_REVISION ($Revision: 1.33 $)
PACKAGE_RELEASE=1
AC_SUBST(PACKAGE_RELEASE)
@@ -202,6 +202,26 @@ using the '--with-diffstat' option.
DIFFSTAT="diffstat"
fi
+dnl Check for sendmail
+AC_ARG_WITH(mta, AC_HELP_STRING(
+ [--with-mta], [mail transfer agent to use]),
+ [
+ MTA="$withval"
+ AC_SUBST(MTA)
+ AC_MSG_NOTICE([Using mail transfer executable $MTA])
+ ],[
+ AC_PATH_PROG(MTA, sendmail, [], [$PATH:/usr/sbin])
+ ])
+if test -z "$MTA"; then
+ AC_MSG_WARN([
+Mail transfer executable not found; the --send option of the mail command
+will not work correctly. If you have a mail transfer agent in a directory
+that is not in the search path you can specify its location using the
+'--with-mta' option.
+])
+ MTA="sendmail"
+fi
+
dnl Check for NLS
AC_ARG_ENABLE(nls, AC_HELP_STRING(
[--enable-nls], [include natural language support]))