summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Gruenbacher <agruen@suse.de>2004-07-09 07:26:21 +0000
committerAndreas Gruenbacher <agruen@suse.de>2004-07-09 07:26:21 +0000
commite7bb642fdbcfa9bb1d7265781f56d89e398f90b9 (patch)
tree1ad9d16ce37e504ba72f9315c94ca9eb95597133 /configure.ac
parentc871d820f8f00819613068aa77cb00d89e4508af (diff)
downloadquilt-e7bb642fdbcfa9bb1d7265781f56d89e398f90b9.tar.gz
- Switch from echo to printf for all translations: This is more
stable than having expansions in messages that might change independent of the message. - Add print_patch function and always use it when printing patch names. Remove -n options from various scripts and use a global switch QUILT_PATCHES_PREFIX in .quiltrc to decide between patch names with and without directory prefix. Depending on user experience this switch may eventually go away. - Add --diffstat option to refresh command: If given, this option inserts diffstat statistics at the end of the patch header, or refreshes the existing diffstat output. No special tags in the path file (%diffstat or the like) are needed. - Minor fix inserting changelog into RPM specfile.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 21 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cc63410..bf33836 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT([quilt],[0.34],[quilt-dev@nongnu.org])
AC_CONFIG_AUX_DIR(config)
AC_PREREQ(2.53)
-AC_REVISION ($Revision: 1.28 $)
+AC_REVISION ($Revision: 1.29 $)
PACKAGE_RELEASE=1
AC_SUBST(PACKAGE_RELEASE)
@@ -182,6 +182,26 @@ else
AC_MSG_RESULT(yes)
fi
+dnl Check for diffstat
+AC_ARG_WITH(diffstat, AC_HELP_STRING(
+ [--with-diffstat], [name of the diffstat executable to use]),
+ [
+ DIFFSTAT="$withval"
+ AC_SUBST(DIFFSTAT)
+ AC_MSG_NOTICE([Using diffstat executable $DIFFSTAT])
+ ],[
+ AC_PATH_PROG(DIFFSTAT, diffstat)
+ ])
+if test -z "$DIFFSTAT"; then
+ AC_MSG_WARN([
+diffstat utility not found; the --diffstat option of the refresh command
+will not work correctly until diffstat is installed. If you have diffstat
+in a directory that is not in the search path you can specify its location
+using the '--with-diffstat' option.
+])
+ DIFFSTAT="diffstat"
+fi
+
dnl Check for NLS
AC_ARG_ENABLE(nls, AC_HELP_STRING(
[--enable-nls], [include natural language support]))