summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJean Delvare <jdelvare@suse.de>2011-03-25 19:51:13 +0100
committerJean Delvare <jdelvare@suse.de>2011-03-25 19:51:13 +0100
commit4b38786ab83b3d804ee31c317d85f695dee05252 (patch)
treef96795006a03698a785e83b4151390d1c03bfd4c /configure.ac
parentb0baeeb6b61132af92fd75df5f912554d295dee1 (diff)
downloadquilt-4b38786ab83b3d804ee31c317d85f695dee05252.tar.gz
configure.ac: Fix test for GNU patch version
We currently ask for GNU patch >= 2.4, but the test suite doesn't actually pass with GNU patch 2.4. It passes with GNU patch 2.5 with minor edits to be more tolerant to the exact output of "patch". I have no idea how much work it would be to get 2.4 to be supported again, but it doesn't seem unreasonable to ask for 2.5 which was released in August 1997. So let's just do that for now. If anyone badly misses support for GNU patch 2.4, well, we accept patches ;) Signed-off-by: Jean Delvare <jdelvare@suse.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1da515a..093ca83 100644
--- a/configure.ac
+++ b/configure.ac
@@ -272,7 +272,7 @@ if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
set -- $patch_version
IFS=$saved_IFS
set -- `echo $1 | $TR -cd 0-9` `echo $2 | $TR -cd 0-9`
- if test 0$1 -lt 2 || test 0$1 -eq 2 -a 0$2 -lt 4 ; then
+ if test 0$1 -lt 2 || test 0$1 -eq 2 -a 0$2 -lt 5 ; then
patch_version=
fi
else
@@ -280,7 +280,7 @@ else
fi
if test -z "$patch_version" ; then
AC_MSG_ERROR([
-$PACKAGE_NAME requires at least version 2.4 of GNU patch. You can download a
+$PACKAGE_NAME requires at least version 2.5 of GNU patch. You can download a
current version of patch from ftp.gnu.org, or if you already have GNU patch
then you can supply its path with the '--with-patch=' option.
])