summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJean Delvare <khali@linux-fr.org>2005-09-21 20:46:21 +0000
committerJean Delvare <khali@linux-fr.org>2005-09-21 20:46:21 +0000
commit48ff26d6f00e06ea37044b345ea36a9b4775eafe (patch)
treed97a7029c28215e39e9bcd639ced92eaece8ecee /configure.ac
parentf072937ae625cf2dd5ca0ae9916a80231eaf270a (diff)
downloadquilt-48ff26d6f00e06ea37044b345ea36a9b4775eafe.tar.gz
- configure.ac, Makefile.in: Make the cp, date and tr binaries
user-selectable. - configure.ac: Test grep and tr features.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 32 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6a0c793..472cb23 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT([quilt],[0.42],[quilt-dev@nongnu.org])
AC_CONFIG_AUX_DIR(config)
AC_PREREQ(2.53)
-AC_REVISION ($Revision: 1.57 $)
+AC_REVISION ($Revision: 1.58 $)
PACKAGE_RELEASE=1
AC_SUBST(PACKAGE_RELEASE)
@@ -53,6 +53,8 @@ version of bash from ftp.gnu.org
])
fi
+QUILT_COMPAT_PROG_PATH(CP, cp, [gcp cp])
+QUILT_COMPAT_PROG_PATH(DATE, date, [gdate date])
QUILT_COMPAT_PROG_PATH(PERL, perl, [perl perl5])
QUILT_COMPAT_PROG_PATH(GREP, grep)
@@ -65,7 +67,19 @@ else
Sorry, you have a version of grep which doesn't understand -q.
$PACKAGE_NAME needs it. If you have access to a version of grep which does
understand -q, you can supply its path with the '--with-grep=' option.
-Solaris users can use /usr/xpg4/bin/grep.
+])
+fi
+
+AC_MSG_CHECKING([whether $GREP understands (foo|bar)])
+if echo first | $GREP '^\(fir\|las\)' >/dev/null 2>&1; then
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([
+Sorry, you have a version of grep which doesn't understand constructs
+of the form (foo|bar). $PACKAGE_NAME needs it. If you have access to
+a version of grep which does understand such constructs, you can supply
+its path with the '--with-grep=' option.
])
fi
@@ -85,6 +99,22 @@ Solaris users can use /usr/xpg4/bin/tail.
])
fi
+QUILT_COMPAT_PROG_PATH(TR, tr)
+
+AC_MSG_CHECKING([whether $TR understands a-z ])
+if test "`echo first | $TR a-z A-Z 2>/dev/null`" = "FIRST"; then
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([
+Sorry, you have a version of tr which doesn't understand constructs
+of the form a-z. $PACKAGE_NAME needs it. If you have access to
+a version of tr which does understand such constructs, you can supply
+its path with the '--with-tr=' option.
+Solaris users can use /usr/xpg4/bin/tr.
+])
+fi
+
QUILT_COMPAT_PROG_PATH(SED, sed)
QUILT_COMPAT_PROG_PATH(AWK, awk, [gawk awk])
QUILT_COMPAT_PROG_PATH(POD2MAN, pod2man)