summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJean Delvare <jdelvare@suse.de>2012-02-01 18:08:49 +0100
committerJean Delvare <jdelvare@suse.de>2012-02-01 18:08:49 +0100
commit372b58dea042ad97fc517c36611441b25732076a (patch)
tree00151cc73ec23b8d55f4dd3fe24a658e73f79e47 /configure.ac
parentc9e79e1e567000b2f9b3c8164f7922f600b00958 (diff)
downloadquilt-372b58dea042ad97fc517c36611441b25732076a.tar.gz
backup-files: Batch mass restore
When restoring all files, batch the first steps (directory creation and target file removal) and last steps (optional touch and backup file removal). This makes the typical restore case (quilt pop) much, much faster. Note: a similar optimization would be possible for the removal function (-x), but quilt doesn't use this function at the moment. Signed-off-by: Jean Delvare <jdelvare@suse.de> Reviewed-by: Raphael Hertzog <hertzog@debian.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 39 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6496e64..0f44a95 100644
--- a/configure.ac
+++ b/configure.ac
@@ -306,8 +306,47 @@ does understand -path, you can supply its path with the
])
fi
+AC_MSG_CHECKING([whether $FIND -print0 works])
+if $FIND . -path '*' -print0 >/dev/null 2>&1; then
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([
+Sorry, you have a version of find which doesn't understand -print0.
+$PACKAGE_NAME needs it. If you have access to a version of find which
+does understand -print0, you can supply its path with the
+'--with-find=' option.
+])
+fi
+
QUILT_COMPAT_PROG_PATH(XARGS, xargs)
+AC_MSG_CHECKING([whether $XARGS -r works])
+if echo | $XARGS -r echo >/dev/null 2>&1; then
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([
+Sorry, you have a version of xargs which doesn't understand -r.
+$PACKAGE_NAME needs it. If you have access to a version of xargs which
+does understand -r, you can supply its path with the
+'--with-xargs=' option.
+])
+fi
+
+AC_MSG_CHECKING([whether $XARGS -0 works])
+if echo | $XARGS -0 echo >/dev/null 2>&1; then
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([
+Sorry, you have a version of xargs which doesn't understand -0.
+$PACKAGE_NAME needs it. If you have access to a version of xargs which
+does understand -0, you can supply its path with the
+'--with-xargs=' option.
+])
+fi
+
QUILT_COMPAT_PROG_PATH_OPT(DIFFSTAT, diffstat)
if test "$DIFFSTAT" != "diffstat"; then