summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJean Delvare <khali@linux-fr.org>2005-09-23 20:34:48 +0000
committerJean Delvare <khali@linux-fr.org>2005-09-23 20:34:48 +0000
commit236b462301524613b57f214f3081e72282dcc30c (patch)
treedb81e2f8c9a0ea14826f5070b975adbf2272ad5e /configure.ac
parenta0439eb454fcbf07f3f9019f29c242a6949925ad (diff)
downloadquilt-236b462301524613b57f214f3081e72282dcc30c.tar.gz
- configure.ac: Let the user select the find binary. Test that find
supports -path.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index acf68b7..17de4a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT([quilt],[0.42],[quilt-dev@nongnu.org])
AC_CONFIG_AUX_DIR(config)
AC_PREREQ(2.53)
-AC_REVISION ($Revision: 1.59 $)
+AC_REVISION ($Revision: 1.60 $)
PACKAGE_RELEASE=1
AC_SUBST(PACKAGE_RELEASE)
@@ -200,6 +200,21 @@ else
AC_MSG_RESULT(yes)
fi
+QUILT_COMPAT_PROG_PATH(FIND, find)
+
+AC_MSG_CHECKING([whether $FIND -path works])
+if $FIND . -path '*' >/dev/null 2>&1; then
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([
+Sorry, you have a version of find which doesn't understand -path.
+$PACKAGE_NAME needs it. If you have access to a version of find which
+does understand -path, you can supply its path with the
+'--with-find=' option.
+])
+fi
+
QUILT_COMPAT_PROG_PATH(DIFFSTAT, [diffstat])
if test -z "$INTERNAL_DIFFSTAT"; then