summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Gruenbacher <agruen@suse.de>2003-07-26 10:52:45 +0000
committerAndreas Gruenbacher <agruen@suse.de>2003-07-26 10:52:45 +0000
commitf179ef136d4517d0b95fc044816c200e9a27e0e1 (patch)
treecc64483f9a2370b7c77a2f887f7d2c1fa22cea47 /configure.ac
parente56a7949db331f7c6703bae4c38b1445747a5918 (diff)
downloadquilt-f179ef136d4517d0b95fc044816c200e9a27e0e1.tar.gz
- Install package documentation into $RPM_DOC_DIR if this
environment variable is set. On RedHat 9 $RPM_DOC_DIR points to /usr/share/doc/packages, but documentation lives in /usr/share/doc. This is a bug in RedHat's RPM configuration; working around it would break other distributions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f23dbec..55dc93f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT([quilt],[0.24],[quilt-dev@nongnu.org])
AC_CONFIG_AUX_DIR(config)
AC_PREREQ(2.53)
-AC_REVISION ($Revision: 1.15 $)
+AC_REVISION ($Revision: 1.16 $)
PACKAGE_RELEASE=1
AC_SUBST(PACKAGE_RELEASE)
@@ -216,6 +216,14 @@ if test -z "$MSGFMT" ; then
AC_MSG_NOTICE([Building without natural language support])
fi
+dnl Determine where package documentation is supposed to go
+if test -n "$RPM_DOC_DIR" ; then
+ docdir="$RPM_DOC_DIR"
+else
+ docdir='$(datadir)/doc'
+fi
+AC_SUBST(docdir)
+
dnl Check for rpmbuild (v4) vs. rpm (v3)
AC_PATH_PROGS(RPMBUILD, [rpmbuild rpm])
AC_SUBST(RPMBUILD)