aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..535b255
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,23 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+"""
+ Setup file for git_deps.
+
+ This file was generated with PyScaffold 2.5.6, a tool that easily
+ puts up a scaffold for your new Python project. Learn more under:
+ http://pyscaffold.readthedocs.org/
+"""
+
+import sys
+from setuptools import setup
+
+
+def setup_package():
+ needs_sphinx = {'build_sphinx', 'upload_docs'}.intersection(sys.argv)
+ sphinx = ['sphinx'] if needs_sphinx else []
+ setup(setup_requires=['six', 'pyscaffold>=2.5a0,<2.6a0'] + sphinx,
+ use_pyscaffold=True)
+
+
+if __name__ == "__main__":
+ setup_package()