aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorsudoforge <no-reply@sudoforge.com>2024-07-18 21:01:04 -0700
committersudoforge <9c001b67637a@sudoforge.com>2024-07-20 16:45:55 -0700
commitbf753031d012b106ddafff2e3bfd4422db5e4935 (patch)
treeea47f526e9036e0ae09bf6bd76f2007e896dcc5f /flake.nix
parenteda0d6723978fa19711b538bf1e9641537959bb3 (diff)
downloadgit-bug-bf753031d012b106ddafff2e3bfd4422db5e4935.tar.gz
feat: add initial nix development shell
This change bootstraps the configuration of a development shell via nix. Change-Id: Ic171e7599b50bb29ecc07d9c4534bcbc117f2299
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 00000000..10cb36bf
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,34 @@
+{
+ description = "workspace configuration for git-bug";
+
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs =
+ {
+ self,
+ flake-utils,
+ nixpkgs,
+ }:
+ flake-utils.lib.eachDefaultSystem (
+ system:
+ let
+ pkgs = nixpkgs.legacyPackages.${system};
+ in
+ {
+ devShell = pkgs.mkShell {
+ packages = with pkgs; [
+ codespell
+ gh
+ git
+ go
+ golangci-lint
+ nixfmt-rfc-style
+ nodePackages.prettier
+ ];
+ };
+ }
+ );
+}