aboutsummaryrefslogtreecommitdiffstats
path: root/Bugs-Everywhere-Web/setup.py
diff options
context:
space:
mode:
authorAaron Bentley <aaron.bentley@utoronto.ca>2006-04-10 22:07:54 -0400
committerAaron Bentley <aaron.bentley@utoronto.ca>2006-04-10 22:07:54 -0400
commit68df9cb4413c2642bac15a940c26e68f9d1391cb (patch)
treecb429c57d740d679a467db3034f93f96ea4e2e33 /Bugs-Everywhere-Web/setup.py
parent16ed63b5c8dc2e211a29ba3636cd00b547ceb9aa (diff)
downloadbugseverywhere-68df9cb4413c2642bac15a940c26e68f9d1391cb.tar.gz
Updated beweb to use TurboGears 0.9
Diffstat (limited to 'Bugs-Everywhere-Web/setup.py')
-rw-r--r--Bugs-Everywhere-Web/setup.py60
1 files changed, 60 insertions, 0 deletions
diff --git a/Bugs-Everywhere-Web/setup.py b/Bugs-Everywhere-Web/setup.py
new file mode 100644
index 0000000..29f1d6f
--- /dev/null
+++ b/Bugs-Everywhere-Web/setup.py
@@ -0,0 +1,60 @@
+from setuptools import setup, find_packages
+from turbogears.finddata import find_package_data
+
+import os
+execfile(os.path.join("beweb", "release.py"))
+
+setup(
+ name="Bugs-Everywhere-Web",
+ version=version,
+
+ # uncomment the following lines if you fill them out in release.py
+ #description=description,
+ #author=author,
+ #author_email=email,
+ #url=url,
+ #download_url=download_url,
+ #license=license,
+
+ install_requires = ["TurboGears >= 0.9a4"],
+ scripts = ["start-beweb.py"],
+ zip_safe=False,
+ packages=find_packages(),
+ package_data = find_package_data(where='beweb',
+ package='beweb'),
+ keywords = [
+ # Use keywords if you'll be adding your package to the
+ # Python Cheeseshop
+
+ # if this has widgets, uncomment the next line
+ # 'turbogears.widgets',
+
+ # if this has a tg-admin command, uncomment the next line
+ # 'turbogears.command',
+
+ # if this has identity providers, uncomment the next line
+ # 'turbogears.identity.provider',
+
+ # If this is a template plugin, uncomment the next line
+ # 'python.templating.engines',
+
+ # If this is a full application, uncomment the next line
+ # 'turbogears.app',
+ ],
+ classifiers = [
+ 'Development Status :: 3 - Alpha',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Framework :: TurboGears',
+ # if this is an application that you'll distribute through
+ # the Cheeseshop, uncomment the next line
+ # 'Framework :: TurboGears :: Applications',
+
+ # if this is a package that includes widgets that you'll distribute
+ # through the Cheeseshop, uncomment the next line
+ # 'Framework :: TurboGears :: Widgets',
+ ],
+ test_suite = 'nose.collector',
+ )
+