aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMartin Vilcans <martin@librador.com>2014-04-03 00:50:23 +0200
committerMartin Vilcans <martin@librador.com>2014-04-03 00:50:23 +0200
commit0ee0f40642f4e53058027947c07154056a26ad6d (patch)
tree3743d1447e166df33dc6b071e00e7036f95b9f7f /setup.py
parente4b83cba87fdd077323831d71402a1775b7435e4 (diff)
downloadscreenplain-0ee0f40642f4e53058027947c07154056a26ad6d.tar.gz
Add setup script
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..8261a7f
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,23 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+setup(
+ name='screenplain',
+ version='0.2',
+ description='Convert text file to viewable screenplay.',
+ author='Martin Vilcans',
+ author_email='screenplain@librador.com',
+ url='http://www.screenplain.com/',
+ packages=[
+ 'screenplain',
+ 'screenplain.export',
+ 'screenplain.parsers',
+ ],
+ package_data={
+ 'screenplain.export': ['default.css']
+ },
+ scripts=[
+ 'bin/screenplain'
+ ]
+)